[PATCH v5 3/9] drm: bridge: inno-hdmi: add inno bridge driver.

Uwe Kleine-König u.kleine-koenig at baylibre.com
Thu Nov 21 14:04:52 UTC 2024


On Thu, Nov 21, 2024 at 02:06:20AM +0000, Keith Zhao wrote:
> 
> 
> > -----Original Message-----
> > From: Uwe Kleine-König <u.kleine-koenig at baylibre.com>
> > Sent: 2024年11月20日 22:56
> > To: Keith Zhao <keith.zhao at starfivetech.com>
> > Cc: devicetree at vger.kernel.org; dri-devel at lists.freedesktop.org;
> > andrzej.hajda at intel.com; neil.armstrong at linaro.org; rfoss at kernel.org;
> > Laurent.pinchart at ideasonboard.com; jernej.skrabec at gmail.com;
> > maarten.lankhorst at linux.intel.com; mripard at kernel.org;
> > tzimmermann at suse.de; airlied at gmail.com; simona at ffwll.ch;
> > robh at kernel.org; krzk+dt at kernel.org; conor+dt at kernel.org;
> > hjc at rock-chips.com; heiko at sntech.de; andy.yan at rock-chips.com; William Qiu
> > <william.qiu at starfivetech.com>; Xingyu Wu <xingyu.wu at starfivetech.com>;
> > kernel at esmil.dk; paul.walmsley at sifive.com; palmer at dabbelt.com;
> > aou at eecs.berkeley.edu; p.zabel at pengutronix.de; Changhuang Liang
> > <changhuang.liang at starfivetech.com>; Jack Zhu <jack.zhu at starfivetech.com>;
> > linux-kernel at vger.kernel.org
> > Subject: Re: [PATCH v5 3/9] drm: bridge: inno-hdmi: add inno bridge driver.
> > 
> > Hello,
> > 
> > On Wed, Nov 20, 2024 at 02:18:42PM +0800, keith zhao wrote:
> > > +struct platform_driver inno_hdmi_driver = {
> > > +	.probe  = inno_hdmi_rockchip_probe,
> > > +	.remove_new = inno_hdmi_rockchip_remove,
> > 
> > Please use .remove instead of .remove_new.
> > 
> Thank you for the clarification regarding .remove_new. 
> I understand that it's a relic and that new drivers should implement .remove().
> 
> I have a question. One of the changes in this patch is to rename some function interfaces. 
> The original code is like this. 
> 
> struct platform_driver inno_hdmi_driver = {
> 	.probe  = inno_hdmi_probe,
> 	.remove_new = inno_hdmi_remove,
> 	.driver = {
> 		.name = "innohdmi-rockchip",
> 		.of_match_table = inno_hdmi_dt_ids,
> 	},
> };
> 
> Rename inno_hdmi_probe and inno_hdmi_remove
> struct platform_driver inno_hdmi_driver = {
> 	.probe  = inno_hdmi_rockchip_probe,
> 	.remove_new = inno_hdmi_rockchip_remove,
> 	.driver = {
> 		.name = "innohdmi-rockchip",
> 		.of_match_table = inno_hdmi_dt_ids,
> 	},
> };
> Based on the principle of maintaining consistency, 
> does it(remove_new) need to be changed?

If this isn't new code but moving from somewhere, don't change
.remove_new into .remove in the same patch. If you want, fix that in a
separate patch then.

Best regards
Uwe
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20241121/16a4706f/attachment.sig>


More information about the dri-devel mailing list