[PATCH v1 6/7] drm/mediatek: mtk_hdmi: Split driver and add common probe function
CK Hu (胡俊光)
ck.hu at mediatek.com
Fri Nov 29 07:28:26 UTC 2024
Hi, Angelo:
On Wed, 2024-11-20 at 13:45 +0100, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
>
>
> In preparation for adding a new driver for the HDMI TX v2 IP,
> split out the functions that will be common between the already
> present mtk_hdmi (v1) driver and the new one.
>
> Since the probe flow for both drivers is 90% similar, add a common
> probe function that will be called from each driver's .probe()
> callback, avoiding lots of code duplication.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno at collabora.com>
> ---
[snip]
> +struct mtk_hdmi_ver_conf {
> + void (*mtk_hdmi_audio_init)(struct mtk_hdmi *hdmi, struct hdmi_codec_pdata *codec_data);
> + const struct drm_bridge_funcs *bridge_funcs;
> + const char * const *mtk_hdmi_clock_names;
> + int num_clocks;
> +};
Because this patch is a little big. So I would like to separate struct mtk_hdmi_ver_conf related part to an independent patch.
The modification is still in mtk_hdmi.c
And the rest part is moving common part to mtk_hdmi_common.c
Regards,
CK
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20241129/8e9fdce6/attachment.htm>
More information about the dri-devel
mailing list