[PATCH 3/7] drm/panic: prefer eliding lifetimes
Jocelyn Falempe
jfalempe at redhat.com
Mon Oct 14 08:46:25 UTC 2024
On 12/10/2024 09:52, Thomas Böhler wrote:
> Eliding lifetimes when possible instead of specifying them directly is
> both shorter and easier to read. Clippy notes this in the
> `needless_lifetimes` lint:
>
> error: the following explicit lifetimes could be elided: 'b
> --> drivers/gpu/drm/drm_panic_qr.rs:479:16
> |
> 479 | fn new<'a, 'b>(segments: &[&Segment<'b>], data: &'a mut [u8]) -> Option<EncodedMsg<'a>> {
> | ^^ ^^
> |
> = help: for further information visit https://rust-lang.github.io/rust-clippy/master/index.html#needless_lifetimes
> = note: `-D clippy::needless-lifetimes` implied by `-D warnings`
> = help: to override `-D warnings` add `#[allow(clippy::needless_lifetimes)]`
> help: elide the lifetimes
> |
> 479 - fn new<'a, 'b>(segments: &[&Segment<'b>], data: &'a mut [u8]) -> Option<EncodedMsg<'a>> {
> 479 + fn new<'a>(segments: &[&Segment<'_>], data: &'a mut [u8]) -> Option<EncodedMsg<'a>> {
> |
>
> Remove the explicit lifetime annotation in favour of an elided lifetime.
>
Thanks, it looks good to me.
Reviewed-by: Jocelyn Falempe <jfalempe at redhat.com>
> Reported-by: Miguel Ojeda <ojeda at kernel.org>
> Closes: https://github.com/Rust-for-Linux/linux/issues/1123
> Signed-off-by: Thomas Böhler <witcher at wiredspace.de>
> ---
> drivers/gpu/drm/drm_panic_qr.rs | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/drm_panic_qr.rs b/drivers/gpu/drm/drm_panic_qr.rs
> index 7adfaa3d6222..767a8eb0acec 100644
> --- a/drivers/gpu/drm/drm_panic_qr.rs
> +++ b/drivers/gpu/drm/drm_panic_qr.rs
> @@ -476,7 +476,7 @@ struct EncodedMsg<'a> {
> /// Data to be put in the QR code, with correct segment encoding, padding, and
> /// Error Code Correction.
> impl EncodedMsg<'_> {
> - fn new<'a, 'b>(segments: &[&Segment<'b>], data: &'a mut [u8]) -> Option<EncodedMsg<'a>> {
> + fn new<'a>(segments: &[&Segment<'_>], data: &'a mut [u8]) -> Option<EncodedMsg<'a>> {
> let version = Version::from_segments(segments)?;
> let ec_size = version.ec_size();
> let g1_blocks = version.g1_blocks();
More information about the dri-devel
mailing list