[PATCH 0/5] Small DRM scheduler improvements
Tvrtko Ursulin
tursulin at igalia.com
Mon Oct 14 10:46:32 UTC 2024
From: Tvrtko Ursulin <tvrtko.ursulin at igalia.com>
Leftovers from the earlier "DRM scheduler fixes and improvements" series.
It looks the fixes have now propagated back to drm-misc-next so this should now
be mergeable.
It also needed a small rebase to account for one revert and one spelling fix
which landed in the meantime.
As a reminder, what remains are kerneldoc improvements, struct layout tweaks for
clarity, one trivial cleanup for the FIFO mode, and most importantly two spin
lock-unlock cycles are removed from the push job path by pulling taking of the
locks one level up.
I smoke tested it on the Steam Deck and lockdep seems happy.
Cc: Christian König <christian.koenig at amd.com>
Cc: Philipp Stanner <pstanner at redhat.com>
Tvrtko Ursulin (5):
drm/sched: Optimise drm_sched_entity_push_job
drm/sched: Stop setting current entity in FIFO mode
drm/sched: Re-order struct drm_sched_rq members for clarity
drm/sched: Re-group and rename the entity run-queue lock
drm/sched: Further optimise drm_sched_entity_push_job
drivers/gpu/drm/scheduler/sched_entity.c | 42 +++++++++++++++---------
drivers/gpu/drm/scheduler/sched_main.c | 32 +++++++++---------
include/drm/gpu_scheduler.h | 28 +++++++++-------
3 files changed, 58 insertions(+), 44 deletions(-)
--
2.46.0
More information about the dri-devel
mailing list