[PATCH v4 00/13] Introduce parity_odd() and refactor redundant parity code
Kuan-Wei Chiu
visitorckw at gmail.com
Wed Apr 9 15:43:43 UTC 2025
Several parts of the kernel contain open-coded and redundant
implementations of parity calculation. This patch series introduces
a unified helper, parity_odd(), to simplify and standardize these
cases.
The first patch renames parity8() to parity_odd(), changes its argument
type from u8 to u64 for broader applicability, and updates its return
type from int to bool to make its usage and return semantics more
intuitive-returning true for odd parity and false for even parity. It
also adds __attribute_const__ to enable compiler optimizations.
While more efficient implementations may exist, further optimization is
postponed until a use case in performance-critical paths arises.
Subsequent patches refactor various kernel components to replace
open-coded parity logic with the new helper, reducing code duplication
and improving consistency.
Co-developed-by: Yu-Chun Lin <eleanor15x at gmail.com>
Signed-off-by: Yu-Chun Lin <eleanor15x at gmail.com>
Signed-off-by: Kuan-Wei Chiu <visitorckw at gmail.com>
---
To H. Peter:
I understand your preference for a parity8/16/32/64() style interface,
and I agree that such a design would better accommodate potential
arch-specific implementations. However, I suspect there are very few,
if any, users who care about the performance of parity calculations
enough to warrant such optimizations. So my inclination is to defer any
arch-specific or optimized implementations until we see parity_odd()
being used in hot paths.
Changes in v4:
- Rename parity8() to parity_odd().
- Change the argument type from u8 to u64.
- Use a single parity_odd() function.
Changes in v3:
- Avoid using __builtin_parity.
- Change return type to bool.
- Drop parity() macro.
- Change parityXX() << y to !!parityXX() << y.
Changes in v2:
- Provide fallback functions for __builtin_parity() when the compiler
decides not to inline it
- Use __builtin_parity() when no architecture-specific implementation
is available
- Optimize for constant folding when val is a compile-time constant
- Add a generic parity() macro
- Drop the x86 bootflag conversion patch since it has been merged into
the tip tree
v3: https://lore.kernel.org/lkml/20250306162541.2633025-1-visitorckw@gmail.com/
v1: https://lore.kernel.org/lkml/20250223164217.2139331-1-visitorckw@gmail.com/
v2: https://lore.kernel.org/lkml/20250301142409.2513835-1-visitorckw@gmail.com/
Kuan-Wei Chiu (13):
bitops: Change parity8() to parity_odd() with u64 input and bool
return type
media: media/test_drivers: Replace open-coded parity calculation with
parity_odd()
media: pci: cx18-av-vbi: Replace open-coded parity calculation with
parity_odd()
media: saa7115: Replace open-coded parity calculation with
parity_odd()
serial: max3100: Replace open-coded parity calculation with
parity_odd()
lib/bch: Replace open-coded parity calculation with parity_odd()
Input: joystick - Replace open-coded parity calculation with
parity_odd()
net: ethernet: oa_tc6: Replace open-coded parity calculation with
parity_odd()
wifi: brcm80211: Replace open-coded parity calculation with
parity_odd()
drm/bridge: dw-hdmi: Replace open-coded parity calculation with
parity_odd()
mtd: ssfdc: Replace open-coded parity calculation with parity_odd()
fsi: i2cr: Replace open-coded parity calculation with parity_odd()
nfp: bpf: Replace open-coded parity calculation with parity_odd()
arch/x86/kernel/bootflag.c | 4 +--
drivers/fsi/fsi-master-i2cr.c | 20 +++------------
.../drm/bridge/synopsys/dw-hdmi-ahb-audio.c | 8 ++----
drivers/hwmon/spd5118.c | 2 +-
drivers/i3c/master/dw-i3c-master.c | 2 +-
drivers/i3c/master/i3c-master-cdns.c | 2 +-
drivers/i3c/master/mipi-i3c-hci/dat_v1.c | 2 +-
drivers/input/joystick/grip_mp.c | 17 ++-----------
drivers/input/joystick/sidewinder.c | 25 ++++---------------
drivers/media/i2c/saa7115.c | 12 ++-------
drivers/media/pci/cx18/cx18-av-vbi.c | 12 ++-------
.../media/test-drivers/vivid/vivid-vbi-gen.c | 8 ++----
drivers/mtd/ssfdc.c | 20 +++------------
drivers/net/ethernet/netronome/nfp/nfp_asm.c | 7 +-----
drivers/net/ethernet/oa_tc6.c | 19 +++-----------
.../broadcom/brcm80211/brcmsmac/dma.c | 18 ++-----------
drivers/tty/serial/max3100.c | 3 ++-
include/linux/bitops.h | 19 ++++++++------
lib/bch.c | 14 +----------
19 files changed, 49 insertions(+), 165 deletions(-)
--
2.34.1
More information about the dri-devel
mailing list