[PATCH v1 11/11] mm/io-mapping: track_pfn() -> "pfnmap tracking"
Lorenzo Stoakes
lorenzo.stoakes at oracle.com
Mon Apr 28 16:06:40 UTC 2025
On Fri, Apr 25, 2025 at 10:17:15AM +0200, David Hildenbrand wrote:
> track_pfn() does not exist, let's simply refer to it as "pfnmap
> tracking".
>
> Signed-off-by: David Hildenbrand <david at redhat.com>
LGTM, so:
Reviewed-by: Lorenzo Stoakes <lorenzo.stoakes at oracle.com>
> ---
> mm/io-mapping.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/mm/io-mapping.c b/mm/io-mapping.c
> index 01b3627999304..7266441ad0834 100644
> --- a/mm/io-mapping.c
> +++ b/mm/io-mapping.c
> @@ -21,7 +21,7 @@ int io_mapping_map_user(struct io_mapping *iomap, struct vm_area_struct *vma,
> if (WARN_ON_ONCE((vma->vm_flags & expected_flags) != expected_flags))
> return -EINVAL;
>
> - /* We rely on prevalidation of the io-mapping to skip track_pfn(). */
> + /* We rely on prevalidation of the io-mapping to skip pfnmap tracking. */
> return remap_pfn_range_notrack(vma, addr, pfn, size,
> __pgprot((pgprot_val(iomap->prot) & _PAGE_CACHE_MASK) |
> (pgprot_val(vma->vm_page_prot) & ~_PAGE_CACHE_MASK)));
> --
> 2.49.0
>
However this doesn't apply after commit b8d8f1830bab ("mm/io-mapping:
precompute remap protection flags for clarity"), so will need a rebase :)
seems this was cleaned up to separate the __pgprot() bit from the
remap_pfn_range_notrack().
Note of course this commit hash is from mm-new so quite changeable... :)
More information about the dri-devel
mailing list