[PATCH v6 14/26] drm/bridge: add support for refcounted DRM bridges
Luca Ceresoli
luca.ceresoli at bootlin.com
Mon Feb 10 17:12:52 UTC 2025
Hello Maxime,
On Fri, 7 Feb 2025 12:47:51 +0100
Maxime Ripard <mripard at kernel.org> wrote:
> > diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h
> > index ad7ba444a13e5ecf16f996de3742e4ac67dc21f1..43cef0f6ccd36034f64ad2babfebea62db1d9e43 100644
> > --- a/include/drm/drm_bridge.h
> > +++ b/include/drm/drm_bridge.h
> > @@ -31,6 +31,7 @@
> > #include <drm/drm_encoder.h>
> > #include <drm/drm_mode_object.h>
> > #include <drm/drm_modes.h>
> > +#include <drm/drm_print.h>
> >
> > struct device_node;
> >
> > @@ -863,6 +864,22 @@ struct drm_bridge {
> > const struct drm_bridge_timings *timings;
> > /** @funcs: control functions */
> > const struct drm_bridge_funcs *funcs;
> > +
> > + /**
> > + * @container_offset: Offset of this struct within the container
> > + * struct embedding it. Used for refcounted bridges to free the
> > + * embeddeing struct when the refcount drops to zero. Unused on
> > + * legacy bridges.
> > + */
> > + size_t container_offset;
>
> This shouldn't be in there. You can create an intermediate structure and
> store both pointers for the action to consume.
You mean to store container_offset + refcount + is_refcounted?
It can be named drm_bridge_object maybe, as it is somewhat resembling
struct drm_mode_object?
> > + /**
> > + * @refcount: reference count for bridges with dynamic lifetime
> > + * (see drm_bridge_init)
> > + */
> > + struct kref refcount;
> > + /** @is_refcounted: this bridge has dynamic lifetime management */
> > + bool is_refcounted;
> > +
>
> I'm not sure we want to treat both paths separately too. It'll require
> to update most of/all the drivers, but it's not too hard with
> coccinelle:
>
> virtual patch
>
> @@
> identifier f;
> identifier b, c, d;
> expression bf;
> type T;
> @@
>
> f(...)
> {
> ...
> - T *c;
> + T *c;
> ...
> - c = devm_kzalloc(d, ...);
> + c = devm_drm_bridge_alloc(d, T, b, bf);
> ...
> - c->b.funcs = bf;
> ...
> drm_bridge_add(&c->b);
> ...
> }
>
> We need to add a bit more variations (like kzalloc vs devm_kzalloc,
> drm_bridge_add vs devm_drm_bridge_add, etc.), but it should be a good
> first approximation
Sure, this can be useful, thanks.
Luca
--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
More information about the dri-devel
mailing list