[PATCH] drm/msm: Use str_enable_disable-like helpers

Abhinav Kumar quic_abhinavk at quicinc.com
Wed Jan 15 21:15:26 UTC 2025



On 1/14/2025 11:17 AM, Krzysztof Kozlowski wrote:
> Replace ternary (condition ? "enable" : "disable") syntax with helpers
> from string_choices.h because:
> 1. Simple function call with one argument is easier to read.  Ternary
>     operator has three arguments and with wrapping might lead to quite
>     long code.
> 2. Is slightly shorter thus also easier to read.
> 3. It brings uniformity in the text - same string.
> 4. Allows deduping by the linker, which results in a smaller binary
>     file.
> 
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski at linaro.org>
> ---
>   .../drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c  |  5 ++--
>   drivers/gpu/drm/msm/disp/mdp5/mdp5_ctl.c      |  3 ++-
>   drivers/gpu/drm/msm/dp/dp_ctrl.c              | 25 ++++++++++---------
>   drivers/gpu/drm/msm/dp/dp_display.c           |  4 +--
>   drivers/gpu/drm/msm/dp/dp_drm.c               |  5 ++--
>   5 files changed, 23 insertions(+), 19 deletions(-)
> 

Interesting helper str_true_false :)

LGTM,

Reviewed-by: Abhinav Kumar <quic_abhinavk at quicinc.com>


More information about the dri-devel mailing list