[Fontconfig] RE: Problems going from RH8 to RH9

Jonathan W. Smith jonathan.w.smith at att.net
Fri Apr 11 00:30:44 EST 2003

I did not get your original reply right away because I opted to receive
posts in Digest format.

Yes, by removing that parameter, the command worked. For nearly 40 seconds,
a long list of fonts scrolled past. It did not hang anywhere, i.e., there
was a normal completion returning me to the command line.

-----Original Message-----
From: Owen Taylor [mailto:otaylor at redhat.com]
Sent: Wednesday, April 09, 2003 9:54 PM
To: jonathan.w.smith at att.net
Cc: fontconfig at fontconfig.org
Subject: Re: Problems going from RH8 to RH9

On Thu, 2003-04-10 at 09:45, Jonathan W. Smith wrote:
> I deleted local.conf and tried running 'strace -e open -e fc-cache -f'. I
> get an error message: invalid system call 'fc-cache'

Try it without the second -e. (Typo on my part, sorry.)


> -----Original Message-----
> From: Owen Taylor [mailto:otaylor at redhat.com]
> Sent: Wednesday, April 09, 2003 7:36 PM
> To: fontconfig at fontconfig.org
> Cc: jonathan.w.smith at att.net
> Subject: Re: [Fontconfig] Re: Problems going from RH8 to RH9
> On Wed, 2003-04-09 at 19:28, Jonathan W. Smith wrote:
> > Luckily,  I was browsing the archives, searching for a possible answer
> my
> > problem, when I came across your reply to my inquiry. There was no way
> a
> > member to reply while browsing the archives, so I created this email as
> I
> > had received your response via email and was replying to it.
> Sorry, forgot to Cc: you last time.
> > How long should it take after 'fc-cache -f' to finish running? I have
> > the machine sit for three hours and it has yet to come back to a command
> > line prompt. Something similar happened previously, I tried running
> > 'redhat-config-xfree86' after creating a local.conf. It started merrily
> off
> > as if great things would happen, yet never came back to the command line
> > prompt. I finally cancelled.
> >
> > I guess I should cancel this effort; delete the local.conf that I
> > and, try running 'fc-cache -f' again.
> Yeah, using the stock fonts.conf would remove a variable. I would
> recommend it.
> fc-cache should take a couple of minutes, no more. If you have thousands
> of fonts from Word Perfect, maybe 5-10 minutes.
> If takes longer than that, I'd run the command as:
>  strace -e open -e fc-cache -f
> And see what font file it hangs on.
> > I am unsure how to answer your question about fonts, other than what
> shipped
> > with RH9. As previously stated, this was an attempt to go from RH8 to
> > There were programs, other than what shipped with RH8 on my machine,
> > installed fonts, e.g., Corel Word Perfect and Sun Star Office. So I
> > assume that the answer to your question is "Yes".
> Depends on _where_ these fonts were installed. If they aren't in
> fontconfig's directories, then they don't matter. But probably yes.
> Regards,
>                                        Owen

More information about the Fontconfig mailing list