[Fontconfig] RE: Problems going from RH8 to RH9

Jonathan W. Smith jonathan.w.smith at att.net
Sat Apr 12 02:26:45 EST 2003

Greg, I followed what you advised; it would seem to be a problem with
fontconfig rather than the X setup. However, Blair on linux.redhat.install

"Your GL libs are jacked up. I think you need to re-install the Mesa
packages, but I may be talking out of my ass. Do a search on rpmfind for
GLcore.so or something similar and you should find the rpm that provides the
libs you need."

I tried installing them by repeating the upgrade process and selecting the
two specific packages:XFree86-Mesa-libGL and XFree86-Mesa-libGLU. That did
not seem to make enough of a difference.

BTW: My XF86Config lacked the first two statement under the Files Section,

        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"

I added those. It did not seem to make enough of a difference. I still get
the fonts missing message.

You wrote:

This is the relevant portion from my XF86Config

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "unix/:7100"

Also when using the X font server you don't need the
freetype and type1 modules loaded in XF86Config

Section "Module"
#       Load  "freetype"
#       Load  "type1"

My /etc/X11/fs/config file looks like this

# font server configuration file
# $Xorg: config.cpp,v 1.3 2000/08/17 19:54:19 cpqbld Exp $

clone-self = on
use-syslog = off
catalogue = /usr/share/fonts/TrueType,

error-file = /var/log/fs-errors
# in decipoints
default-point-size = 120
default-resolutions = 92,92,75,75

# font cache control, specified in KB
cache-hi-mark = 2048
cache-low-mark = 1433
cache-balance = 70

I am sure that RedHat has their own way of doing these so
don't just blindly copy these!!!

You should be able to restart the font server by
logging in as root and entering the command

/etc/rc.d/init.d/xfs restart

then enter

ps ax | grep xfs

and look for something like this

13062 ?        S      0:03 /usr/X11R6/bin/xfs -droppriv -daemon

if you don't see it, you have X setup problems and not fontconfig ones.

More information about the Fontconfig mailing list