[Fontconfig] Installed 2.1.94 - dependencies, fails to read win\fonts and local.conf

sean darcy seandarcy at hotmail.com
Sat Apr 19 09:54:54 EST 2003

I've installed 2.1.94. Sure makes the new Bitstream fonts look great.

Some suggestions - questions:

1. the fontconfig.spec file should have a Requires for freetype-2.1.4.

2. The present spec file overwrites local.conf. I thought local.conf was 
where we put  system-wide stuff that wouldn't be overwritten like 

3. the local.conf that is put there is odd.

  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                <edit name="rgba" mode="assign"><const>rgb</const></edit>

I don't know much - any - XML, but isn't it all commented out? Should it be 
uncommented? Shouldn't it be in fonts.conf?

4. I have a dual boot machine. i'd like to use all the ttf fonts I have in 
the windows font directory. But when I run fc-cache I get:

[root at amd1900 Fonts]# fc-cache -v .
fc-cache: ".": skipping, 240 fonts, 0 dirs
fc-cache: succeeded

Which appears to mean it skipped all the fonts. I realize some ( maybe 
10-15) are not truetype, but should it skip them all?

I then tried:

[root at amd1900 Fonts]# fc-cache -v -f /win/ddrive/Winnt/Fonts
fc-cache: "/win/ddrive/Winnt/Fonts": Segmentation fault

Any  thoughts?


Add photos to your messages with MSN 8. Get 2 months FREE*.  

More information about the Fontconfig mailing list