[Fontconfig] Problems finding fonts

Roger Svensson rsvdv96 at student.vxu.se
Fri Feb 21 18:53:01 EST 2003


I'm having a little trouble with Pango/Fontconfig on my Debian 3.0 box with Xfree86-4.2.1 and Gnome built from source. I'm running fontconfig-2.1 built using instructions found in the wiki.

I was on a mission to upgrade GTK and friends to the latest versions:

Everything seemed fine until I tried starting Gnome which failed with a message that it could not find font Verdana -10.

I have all of my TT-fonts installed in /opt/fonts and I did add a row to the fonts.conf file:
in the proper section of the file.

If I run "fc-list", it sure tells me I've got the Verdana font installed.

I also tried removing the /opt/fonts entry from fonts.conf and added a symlink, ~/.fonts -> /opt/fonts with the same poor result.

I figure the problem is fontconfig related since reverting to old GTK/GLIB/Pango work just fine. Also, un-setting the GDK_USE_XFT variable work, but then I won't get any TT fonts at all. 

I obviously overlooked something, problem is I can't understand what. 


More information about the Fontconfig mailing list