[Fontconfig] Fontconfig Issue

Rob rrowens at earthlink.net
Sun Jan 19 09:18:57 EST 2003

On Sat, 18 Jan 2003 10:56:07 -0800
Keith Packard <keithp at keithp.com> wrote:

> Around 12 o'clock on Jan 18, Rob wrote:
> > The problem I'm having is font related. I have a number of high quality
> > type 1 postscript fonts on this machine. When I use the application with
> > the non-Xft build of GTK+ all of my fonts appear in the font selection
> > process of that application. When I use the Xft-enabled build of GTK+, I
> > only have a minimal set of non-postscript fonts to choose from in the
> > selection process.
> You need to make sure that fontconfig knows where the fonts are installed.
> /etc/fonts/fonts.conf has a list of directories; you can place your fonts 
> in any directory or subdirectory of those listed (usually /usr/share/fonts
> and /usr/X11R6/lib/X11/fonts).  If they're elsewhere, you can either add 
> the new directory name to a configuration file or move them.
> Keith Packard        XFree86 Core Team        HP Cambridge Research Lab

Thanks for the information.

Adding existing font directory paths to the font.conf file was one of the first things I tried to get this to work. If I tried to bring up the application, it would crash and a message appeared indicating that the fonts.conf and fonts.dtd file weren't synchronised. I subsequently deleted the offending line and the problem went away. BTW, the font path entry was of the same format as existing entries.

Since the /usr/share/fonts and the ~/.fonts directories did not exist, I simply created symbolic links to point to where existing fonts were located. This worked very well and now my Unix fonts look better than they ever have.

What did the message stating "the fonts.conf and fonts.dtd files were not synchronised" mean?


More information about the Fontconfig mailing list