[Fontconfig] c-list weirdness in fontconfig 2.3.0 regarding FcFini

greg smith gasmith3 at wisc.edu
Fri Apr 8 08:54:33 EST 2005


I've been trying to install fontconfig 2.3.0 on a distributed system,
and I'm having a bit of trouble doing so. First, I should explain that
all OSS software is kept on an AFS server. Linux & Solaris machines are
hooked up to this server, and the links are craftily arranged so that
each system only sees its own binaries, libraries, etc.

As you might imagine, it's a nightmare. However, I generally don't have
too many problems getting things to work properly.

Anyways, here's my problem:

When I try to build fontconfig under Linux, it compiles and links
properly - but the test fails. I currently have things configured thusly:

./configure --prefix=/afs/engr.wisc.edu/oss/fontconfig-2.3.0/i386_linux24

I have also tried: (as well as many other combinations of the below flags)

--enable-dependency-tracking --disable-fast-install

I do not recieve any errors or warnings during compile/link time, but
when it comes time for the testing, this is the output from run-test.sh:

relocation error:
undefined symbol: FcFini
relocation error:
undefined symbol: FcFini
relocation error:
undefined symbol: FcFini
*** Test failed: Basic check
*** output is in 'out', expected output in 'out.expected'

I am using freetype2, but an older version of freetype is installed in
the system for the sake of old dependencies.

I have tried using cc and gcc, with both make and gmake.

These are the applicable environment variables:

# directory crap to make the following more readable
ARCH=`/usr/afsws/bin/fs sysname | cut -d \' -f2`

# C(++) compiler

# compiler/linker flags, etc
CPPFLAGS="-I$OSS/include/freetype2 -I$OSS/include"
CFLAGS="-O2 -Wall"
LDFLAGS="-Wl,--rpath -Wl,$OSS/$FOLDER/$ARCH/lib
-Wl,-L$OSS/$FOLER/$ARCH/lib -Wl,--rpath -Wl,$OSS/lib -Wl,-L$OSS/lib

# path

I decided to try running src/.libs/fc-list for myself, and I found that
the output it produced was **IDENTICAL** to that of fc-list from my
previous installation of fontconfig - the only obvious difference being
the "relocation error"/"undefined symbol" message at the end.

Another (perhaps unrelated problem) is that gcc was not linking properly
with libiconv; hence the manual "-Wl,-liconv" in the LDFLAGS environment

Please help, this installation has given me no end of frustration in the
past couple days.


More information about the Fontconfig mailing list