[Fontconfig] fontconfig 2.2.98 link error - can not find libgcc_s.so.1

Rupa Kamoji rkamoji at knightsindia.co.in
Thu Feb 23 22:33:18 PST 2006



I have installed fontconfig 2.2.98 and freetype version 2.1.10 to have
font scaling. When I compile my application with these libraries, I am
getting following error


ld: warning: file libgcc_s.so.1: required by
/usr/openwin/lib/libfontconfig.so, not found

Undefined                       first referenced

 symbol                             in file

libiconv_open                       /usr/openwin/lib/libfontconfig.so

libiconv                            /usr/openwin/lib/libfontconfig.so


I am using gcc 2.95.3 to compile my application. To resolve this
problem, I compiled fontconfig with gcc 2.95.3 and then compiled my
application. But still I am getting the same error.


How should I get rid of this problem? Which version of fontconfig should
I use to resolve this?


I am using fontconfig 2.1.0 on linux. This was installed by the
installation of XFree86 4.5.0. I don't have any problem there. I tried
looking for fontconfig version 2.1.0 on the net, but I am not getting.
Can you please tell me from where I can get fontconfig version 2.1.0?


Thanks and Regards,



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/fontconfig/attachments/20060224/e4f1d920/attachment.html

More information about the Fontconfig mailing list