[Fontconfig] AppleRoman-DynaFont.patch

Behdad Esfahbod behdad at behdad.org
Thu Feb 5 09:25:49 PST 2009

Mike FABIAN wrote:
> Mike FABIAN <mfabian at suse.de> さんは書きました:
>> Behdad Esfahbod <behdad at behdad.org> さんは書きました:
>>> AppleRoman-DynaFont.patch:  Any reason why those entries are being removed
>>> from the AppleRoman encoding?
>> Very old bug, unfortunately not publicly visible I think because
>> our bugzilla was not yet public at that time. I have moved
>> the bug to openSUSE 11.2 Alpha0 and hope it is visible now:
>> https://bugzilla.novell.com/show_bug.cgi?id=53243
>> As you can see in the bug report, the submitter of this patch, Zhe Su
>> couldn't tell me either what this patch does.  Apparently it had
>> something to do with the commercial Japanese Dynafont font series,
>> therefore I tried to get hold of these fonts and do some testing and
>> found that weird glyphs at completely wrong positions were displayed
>> without this patch. The patch seemed to have no effect whatsoever on
>> other fonts.
>> I’ll try now if the situation is still the same and the wrong
>> glyphs reappear if I disable the patch.
> The situation is unchanged, the dynafonts still display the same
> wrong glyphs if I disable the patch.

So, it's the case of a buggy fonts.  When we have support for removing certain
glyphs from a font pattern you can use that to blacklist these glyphs.

As for whether fontconfig is right or wrong, I crosschecked the table with:


and the fontconfig version is correct, but missing the entries 0xE0 to 0xFF.
Maybe there's good reason for not including those, and that reason may extend
to the ones you are removing.  I have no idea.  Keith?


More information about the Fontconfig mailing list