[Fontconfig] Build issues on MSYS64 - ImportError: No module named lxml

Ron Gaw <ronmlgaw at yahoo dot com> ronmlgaw at yahoo.com
Thu Dec 29 03:59:26 UTC 2016

I've been trying to solve this on my own for several weeks now, to no avail.  Below I will share:1. ./configure output (the parts I *think* are relevant to the error)2. make output (spoiler alert : fails with the subject line error)3. description of my attempts to compile lxml
Pre-step: THE BASICS:
    System - MSYS2 / MINGW64    LIBRARY_PATH=C:/msys64/usr/local/lib;
    PATH=/mingw64/bin:/usr/local/bin:/usr/bin:/bin:/c/Windows/System32:/c/Windows: \        /c/Windows/System32   /Wbem:/c/Windows/System32/WindowsPowerShell/v1.0/: \        /usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
    PKG_CONFIG_PATH=/usr/local/lib/pkgconfig    CC=/mingw64/bin/x86_64-w64-mingw32-gcc (gcc version is 6.2.0-2)
    CFLAGS=-I/usr/local/include -O3    msys/python2 2.7.11-1
Step 1: ./configure  --disable-docs --enable-shared --enable-staticOUTPUT:
..... (stuff that I don't think is relevant is not shown....) .....
checking for pkg-config... /mingw64/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for python... no
checking for python2... /usr/bin/python2
checking for python version... 2.7
checking for python platform... msys
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for RM macro... rm -f
checking build system type... x86_64-w64-mingw32
checking host system type... x86_64-w64-mingw32.....
Step 2: makeOUTPUT:make  all-recursive
make[1]: Entering directory '/home/Ron/src/fontconfig-2.12.1'
Making all in fontconfig
make[2]: Entering directory '/home/Ron/src/fontconfig-2.12.1/fontconfig'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/Ron/src/fontconfig-2.12.1/fontconfig'
Making all in fc-blanks
make[2]: Entering directory '/home/Ron/src/fontconfig-2.12.1/fc-blanks'
  GEN      fcblanks.h
Traceback (most recent call last):
  File "./fc-blanks.py", line 14, in <module>
    from lxml import html
ImportError: No module named lxml
make[2]: *** [Makefile:595: fcblanks.h] Error 1
Step 3: lxml- I have tried searching (using pacman -Ss lxml), but the only python2-lxml is built for mingw64-w64-x86_64-python2, and that particular python2 creates it's own set of errors (mostly because it by default seems to choose Windows PATH formatting instead of using UNIX-like paths).- I have downloading and tried building lxml (successfully built both libxml2 and libxslt and installed them in /usr/local, all my attempts to build libxml2-python-2.6.9 end in errors shortly after starting ./setup.py install)

I recognize this might really be an lxml issue, but I'm hoping I'm not the first / only one to experience this and there's a simple setting / environment / download I can apply.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/fontconfig/attachments/20161229/17af0bd6/attachment.html>

More information about the Fontconfig mailing list