[Fontconfig] Fw: cross-compile stopped working circa mid Jan2016

hydra3333 at gmail.com hydra3333 at gmail.com
Sat Feb 20 00:25:23 UTC 2016

Thank you.

>  is it reproducible with a simple code containing a line of 
> MemoryBarrier()?

Unfortunately I don't yet know how to create and "make" a file from scratch.
I'll get there, find a link to a beginners tute somewhere, but am stuck just 

> Well, tried to build with mingw64-gcc 5.2.0 and 6.0.0 snapshot on
> Fedora and 4.9.2 on Ubuntu 15.10 (all of mingw is installed via their
> packaging system) and no problems. dunno how you installed your mingw
> that contains gcc 5.3.0 though,

Here's the commandlines which downloads and compiles/installs a mingw which 
"fails": (for 5.2.0):

zeranoe_script_options="--clean-build --build-type=multi --disable-shared --default-configure 
 --allow-overwrite --rebuild-all --threads=pthreads-w32 --pthreads-w32-ver=2-9-1 
 --cpu-count=2 --gcc-ver=5.2.0 --enable-gendef --enable-widl"
curl -4 http://zeranoe.com/scripts/mingw_w64_build/$zeranoe_script_name -O
chmod u+x $zeranoe_script_name
nice ./$zeranoe_script_name $zeranoe_script_options --build-type=win32
nice ./$zeranoe_script_name $zeranoe_script_options --build-type=win64

Here's the instructions per 
https://github.com/rdp/ffmpeg-windows-build-helpers which end up failing at 
Please note that this uses a modified version of the mingw install script 
however I have tried both the above and the modified mingw install in the 
below, with the same result in both.
- install dependencies
sudo apt-get install -y subversion curl texinfo g++ bison flex cvs yasm 
automake libtool autoconf gcc cmake git make pkg-config zlib1g-dev mercurial 
unzip pax
# ?? for zlib.h
# sudo apt-get install -y zlib1g-dev
- download zip file: 
- unzip it
cd ffmpeg-windows-build-helpers
# initiate mingw install and the ffmpeg build. crashes at fontconfig build 
./cross_compile_ffmpeg.sh --gcc-cpu-count=2 --sandbox-ok=y --build-ffmpeg-shared=n 
 --build-ffmpeg-static=y --disable-nonfree=n --build-libmxf=n --build-mp4box=y 
 --build-mplayer=n --build-vlc=y --build-dvbtee=y --git-get-latest=y --prefer-stable=n 
 --high-bitdepth=n --compiler-flavors=win32 --cflags=-march=sandybridge
- wait

I am beginning to feel (with no basis in knowledge for it) as if it's 
something to do with my ubuntu install.

I'll try to modify the above script to install "mingw via their packaging 
system" and reference it instead.

More information about the Fontconfig mailing list