[Freedreno] [PATCH 02/16] drm/msm: Rename the MSM driver so it doesn't conflict with other drivers

Jordan Crouse jcrouse at codeaurora.org
Fri Nov 4 22:44:43 UTC 2016


MSM is a very loaded name. Rename it to msm-drm to make it a little
bit more descriptive and to (kinda) avoid namespace contamination.

Signed-off-by: Jordan Crouse <jcrouse at codeaurora.org>
---
 drivers/gpu/drm/msm/msm_drv.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/gpu/drm/msm/msm_drv.c b/drivers/gpu/drm/msm/msm_drv.c
index 8a02370..1c749a2 100644
--- a/drivers/gpu/drm/msm/msm_drv.c
+++ b/drivers/gpu/drm/msm/msm_drv.c
@@ -1057,7 +1057,7 @@ static struct platform_driver msm_platform_driver = {
 	.probe      = msm_pdev_probe,
 	.remove     = msm_pdev_remove,
 	.driver     = {
-		.name   = "msm",
+		.name   = "msm-drm",
 		.of_match_table = dt_match,
 		.pm     = &msm_pm_ops,
 	},
-- 
1.9.1



More information about the Freedreno mailing list