[PATCH v4 0/2] drm/atomic-helper: rename drm_atomic_helper_check_wb_encoder_state
Dmitry Baryshkov
dmitry.baryshkov at linaro.org
Fri Dec 8 01:03:12 UTC 2023
The function drm_atomic_helper_check_wb_encoder_state() doesn't use
drm_encoder for anything sensible. Internally it checks
drm_writeback_connector's state. Thus it makes sense to let this
function accept drm_connector object and the drm_atomic_state
and rename it to drm_atomic_helper_check_wb_connector_state().
Changes since v3:
- Fix the function usage in vkms_wb_encoder_atomic_check() (Maxime)
Changes since v2:
- Make the function accept drm_connector instead of
drm_writeback_connector (Maxime)
Changes since v1:
- Make the function accept drm_writeback_connector and drm_atomic_state
(Maxime)
- Added a patch for VKMS to move atomic_check of WB path from encoder to
connector helpers.
Dmitry Baryshkov (2):
drm/atomic-helper: rename drm_atomic_helper_check_wb_encoder_state
drm/vkms: move wb's atomic_check from encoder to connector
drivers/gpu/drm/drm_atomic_helper.c | 16 +++++++++-------
drivers/gpu/drm/vkms/vkms_writeback.c | 25 +++++++++++++++----------
include/drm/drm_atomic_helper.h | 5 ++---
3 files changed, 26 insertions(+), 20 deletions(-)
--
2.39.2
More information about the Freedreno
mailing list