[Freedreno] [PATCH v11 2/9] drm/display/dsc: add helper to set semi-const parameters
Jessica Zhang
quic_jesszhan at quicinc.com
Wed May 17 21:38:48 UTC 2023
On 5/17/2023 2:15 PM, Marijn Suijten wrote:
> On 2023-05-17 11:51:11, Jessica Zhang wrote:
>> From: Dmitry Baryshkov <dmitry.baryshkov at linaro.org>
>>
>> Add a helper setting config values which are typically constant across
>> operating modes (table E-4 of the standard) and mux_word_size (which is
>> a const according to 3.5.2).
>>
>> Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov at linaro.org>
>> Reviewed-by: Marijn Suijten <marijn.suijten at somainline.org>
>> Signed-off-by: Jessica Zhang <quic_jesszhan at quicinc.com>
>> ---
>> drivers/gpu/drm/display/drm_dsc_helper.c | 22 ++++++++++++++++++++++
>> include/drm/display/drm_dsc_helper.h | 1 +
>> 2 files changed, 23 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/display/drm_dsc_helper.c b/drivers/gpu/drm/display/drm_dsc_helper.c
>> index 65e810a54257..b9c4e10ced41 100644
>> --- a/drivers/gpu/drm/display/drm_dsc_helper.c
>> +++ b/drivers/gpu/drm/display/drm_dsc_helper.c
>> @@ -270,6 +270,28 @@ void drm_dsc_pps_payload_pack(struct drm_dsc_picture_parameter_set *pps_payload,
>> }
>> EXPORT_SYMBOL(drm_dsc_pps_payload_pack);
>>
>> +/**
>> + * drm_dsc_set_const_params() - Set DSC parameters considered typically
>> + * constant across operation modes
>> + *
>> + * @vdsc_cfg:
>> + * DSC Configuration data partially filled by driver
>> + */
>> +void drm_dsc_set_const_params(struct drm_dsc_config *vdsc_cfg)
>> +{
>> + if (!vdsc_cfg->rc_model_size)
>> + vdsc_cfg->rc_model_size = DSC_RC_MODEL_SIZE_CONST;
>> + vdsc_cfg->rc_edge_factor = DSC_RC_EDGE_FACTOR_CONST;
>> + vdsc_cfg->rc_tgt_offset_high = DSC_RC_TGT_OFFSET_HI_CONST;
>> + vdsc_cfg->rc_tgt_offset_low = DSC_RC_TGT_OFFSET_LO_CONST;
>> +
>> + if (vdsc_cfg->bits_per_component <= 10)
>> + vdsc_cfg->mux_word_size = DSC_MUX_WORD_SIZE_8_10_BPC;
>> + else
>> + vdsc_cfg->mux_word_size = DSC_MUX_WORD_SIZE_12_BPC;
>> +}
>> +EXPORT_SYMBOL(drm_dsc_set_const_params);
>> +
>> /* From DSC_v1.11 spec, rc_parameter_Set syntax element typically constant */
>> static const u16 drm_dsc_rc_buf_thresh[] = {
>> 896, 1792, 2688, 3584, 4480, 5376, 6272, 6720, 7168, 7616,
>> diff --git a/include/drm/display/drm_dsc_helper.h b/include/drm/display/drm_dsc_helper.h
>> index 528dfb5e25fc..ea99b0b90674 100644
>> --- a/include/drm/display/drm_dsc_helper.h
>> +++ b/include/drm/display/drm_dsc_helper.h
>> @@ -21,6 +21,7 @@ void drm_dsc_dp_pps_header_init(struct dp_sdp_header *pps_header);
>> int drm_dsc_dp_rc_buffer_size(u8 rc_buffer_block_size, u8 rc_buffer_size);
>> void drm_dsc_pps_payload_pack(struct drm_dsc_picture_parameter_set *pps_sdp,
>> const struct drm_dsc_config *dsc_cfg);
>> +void drm_dsc_set_const_params(struct drm_dsc_config *vdsc_cfg);
>> void drm_dsc_set_rc_buf_thresh(struct drm_dsc_config *vdsc_cfg);
>> int drm_dsc_setup_rc_params(struct drm_dsc_config *vdsc_cfg, enum drm_dsc_params_kind kind);
>
> Dmitry changed this to `type` in "drm/i915: move DSC RC tables to
> drm_dsc_helper.c" v6/7, hope that's not going to give context conflicts
> on a strict apply/merge.
Hi Marijn,
Thanks for the heads up -- I'll rebase on top of the latest version of
that series.
Thanks,
Jessica Zhang
>
> - Marijn
>
>> int drm_dsc_compute_rc_parameters(struct drm_dsc_config *vdsc_cfg);
>>
>> --
>> 2.40.1
>>
More information about the Freedreno
mailing list