Position API rewrite

Jussi Kukkonen jhkukkon at cc.hut.fi
Sat Aug 11 01:22:43 PDT 2007


keith preston wrote:
> Ok, so from the last e-mail, I have been doing a lot of work to improve the
> Position API and I have finally committed in my changes.  Please take a look
> and comment on anything else that we should add to the API.   I am going to
> be working on documentation next week and hopefully we can help gajim
> integrate with geoclue.


Looks good to me. For others' convenience:

The commit includes at least this:
* org.foinse_project.geoclue -> org.freedesktop.geoclue rename
* some bugfixes, numerous readability changes
* new C-wrapper initialization
* position API changes:
  - method "service_provider" is now "service_name"
  - current_position is now
         <method name="current_position">
           <arg type="i" name="timestamp" direction="out" /> <!-- new-->
           <arg type="d" name="latitude" direction="out" />
           <arg type="d" name="longitude" direction="out" />
           <arg type="d" name="altitude" direction="out" /> <!-- new-->
         </method>
  - current_velocity has similar additions as current_position
  - current_position_error is now
         <method name="current_position_error">
           <arg type="d" name="latitude_error" direction="out" />
           <arg type="d" name="longitude_error" direction="out" />
           <arg type="d" name="altitude_error" direction="out"/>
         </method>
  - new service_status method and signal:
         <method name="service_status">
           <arg type="i" name="status" direction="out"/>
           <arg type="s" name="user_message" direction="out"/>
         </method>
         <signal name="service_status_changed">
           <arg type="i" name="status" direction="out"/>
           <arg type="s" name="user_message" direction="out"/>
         </signal>
  - service_available method removed
  - position_status enum is now bit
  - more return codes for position methods



Keith, I haven't tested anything much, but one thing that I'd like to
change (in future commits) is the indentation. I use 4-space indent too,
but for others the code is difficult to read in places. gitweb diffs are
a good example. Currently you have things like this:

<tab>method_call (<tab>arg1,
<tab><tab>             arg2);

That works only with a specific indent size. This would be better:

<tab>method_call ( arg1,
<tab>              arg2);

-jussi

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 307 bytes
Desc: OpenPGP digital signature
Url : http://lists.freedesktop.org/archives/geoclue/attachments/20070811/e6e8adb6/attachment.pgp 


More information about the GeoClue mailing list