[gstreamer-bugs] [Bug 597822] Add removesilence plugin
GStreamer (bugzilla.gnome.org)
bugzilla at gnome.org
Wed Dec 30 12:25:12 PST 2009
https://bugzilla.gnome.org/show_bug.cgi?id=597822
GStreamer | gst-plugins-bad | git
Stefan Kost (gstreamer, gtkdoc dev) <ensonic> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #145078|none |needs-work
status| |
--- Comment #5 from Stefan Kost (gstreamer, gtkdoc dev) <ensonic at sonicpulse.de> 2009-12-30 20:25:10 UTC ---
Review of attachment 145078:
--> (https://bugzilla.gnome.org/review?bug=597822&attachment=145078)
::: gst/removesilence/gstremovesilence.c
@@ +1,3 @@
+/*
+ * GStreamer
+ * @author Tiago Katcipis <tiagokatcipis at gmail.com>
this looks a bit differnt in gstreamer files usualy
@@ +107,3 @@
+ GST_STATIC_CAPS ("audio/x-raw-int, rate=[1, 2147483647], channels=1,
endianness=1234, width=16, depth=16, signed=true")
+ );
+
not critical fro getting it in, but supporting more formats natively would be
nice (e.g. width/depth). Also do you have any thoughts on how this would work
with e.g. stereo or more channels?
@@ +185,3 @@
+ filter->remove = FALSE;
+ filter->last_timestamp = 0;
+ filter->vad = vad_new();
Don't you need to reset this during state changes (e.g. to make it work if the
element is used a 2nd time)?
@@ +196,3 @@
+ const GValue * value, GParamSpec * pspec)
+{
+ GstRemoveSilence *filter = GST_REMOVESILENCE (object);
The macro should be called GST_REMOVE_SILENCE.
::: gst/removesilence/vad_private.h
@@ +56,3 @@
+#define VAD_HYSTERESIS 480 /* 60 mseg */
+
+#define DEFAULT_ADAPTATIVE_TIMER 100 /* mseg */
wouldn't it make sense to have some of those as gobject properties?
--
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.
More information about the Gstreamer-bugs
mailing list