[Bug 518857] [API] GstBaseParse: new base class for parsers

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Sat Mar 12 12:04:23 PST 2011


https://bugzilla.gnome.org/show_bug.cgi?id=518857
  GStreamer | gstreamer (core) | git

Tim-Philipp Müller <t.i.m> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |NEW
     Ever Confirmed|0                           |1

--- Comment #22 from Tim-Philipp Müller <t.i.m at zen.co.uk> 2011-03-12 20:04:21 UTC ---
So, I've basically moved this into libgstbase in my local core, and fixed up a
few minor things up here and there.

I noticed a few cosmetic issues when reviewing the API (let's just try to
decide what we want to do and I'll fix it up locally):

 - gst_base_parse_set_seek() => rename to ???
   (set_seekable, set_seekability, set_seek_type, set_seek_mode?)

 - or maybe get rid of gst_base_parse_set_seek() entirely, and just
   have _set_bitrate()? Or add a separate _set_average_bitrate()?

 - GstBaseParseSeekable => GstBaseParseSeekability or GstBaseParseSeekMode?
   (see above)

 - Name mismatch with "GstBaseParse*Seekable*" and
GST_BASE_PARSE_*SEEK*_DEFAULT
   (should be renamed according to whatever is decided above)

 - GST_BASE_PARSE_SEEK*_DEFAULT => GST_BASE_PARSE_SEEK*_BITRATE?

 - gst_base_parse_set_format() looks a bit weird API-wise ("gboolean on"),
maybe
   make it {set|unset}_format_flag() or something like that?

 - gst_base_parse_set_frame_props() -> gst_base_parse_set_frame_properties()?

 - should we add some padding to GstBaseParseFrame? (better safe than sorry
etc.)

 - GstBaseParseFrame: shouldn't flags be GstBaseParseFrameFlags instead of
guint

 - does GstBaseParse::segment need to be exposed? (nothing uses it afaict)

 - does GstBaseParse::pending_segment need to be exposed? (nothing uses it
afaict)

 - does GstBaseParse::close_segment need to be exposed? (nothing uses it
afaict)

 - does GstBaseParse::adapter need to be exposed? (nothing uses it afaict)

 - GST_BASE_PARSE_{SRC,SINK}_NAME -> unused, let's remove it (seems pointless
too)

 - GST_BASE_PARSE_FRAME_SYNC() -> rename to express booleaness?
   (maybe easier if we make it negative, like LOST_SYNC)

 - GST_BASE_PARSE_FRAME_DRAIN() -> rename to express booleaness?
({IS?}_DRAINING?)

 - GST_BASE_PARSE_FRAME_{DRAIN,SYNC} - shouldn't "draining" and "in sync"
status
   be something on GstBaseParse rather than GstBaseParseFrame? (maybe add API
to
   get status for those?)

-- 
Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list