[Bug 658691] New: Gstreamer Backend causes choppy sound

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Fri Sep 9 19:58:38 PDT 2011

  GStreamer | don't know | 0.10.x

           Summary: Gstreamer Backend causes choppy sound
    Classification: Platform
           Product: GStreamer
           Version: 0.10.x
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: Normal
         Component: don't know
        AssignedTo: gstreamer-bugs at lists.freedesktop.org
        ReportedBy: steffeneibicht at yahoo.de
         QAContact: gstreamer-bugs at lists.freedesktop.org
     GNOME version: ---

Created an attachment (id=196158)
 --> (https://bugzilla.gnome.org/attachment.cgi?id=196158)
terminal outputs when starting amarok


Gstreamer causes choppy sound when used as Audio Backend. I ran/run 4 different
Linux systems on 4 different hardware systems  and all of them have a choppy
sound when Gstreamer is used. 
This chopping sounds like there is too much load on the system, as the
processor couldn´t cope with the load. But when I switch the Audio Backend to
Xine (on KDE) the choppy sound is away. Listening to music is fun again.

Systems used:
- Fedora 14 (Gnome)
- Linux Mint 11 (Gnome)
- openSUSE 11.3 and 11.4 (both, Gnome and KDE)

- used with openSUSE 11.3 and 11.4 (KDE) and Fedora 14 (two devices):

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio


00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High
Definition Audio (rev 05)

- used with Linux Mint 11:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 03)

- used with openSUSE 11.4 Gnome:

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio
Controller (rev 02)

All systems have the right plugins and codecs. The soundfile format used is
.ogg. But this chopping also occurs when listening to .mp3 and radio streams
over the internet. It occurs all the time, when music is playing.
I tried different things to get rid of it: removing Pulseaudio, different
settings... all didn´t work. Just switching to Xine does the job.
I know that 1 year ago or so, Gstreamer did not have this issue. So I would be
very grateful if you could fix this issue. 
If I can help you with logfiles, terminal outputs or whatever, just drop me a
mail. Just in case it helps you, I attached a textfile of the terminal outputs
when starting Amarok with Gstreamer as Backend. 

thanks and best Regards

Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the gstreamer-bugs mailing list