[Bug 657179] pulse: New pulsedecsink element to handle format changes

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Mon Sep 12 06:21:37 PDT 2011

  GStreamer | gst-plugins-good | unspecified

--- Comment #10 from Tim-Philipp Müller <t.i.m at zen.co.uk> 2011-09-12 13:21:29 UTC ---
No, I did not mean to suggest pulseaudiosink.

We've discussed this on IRC multiple times now, and there just isn't a great

Whatever we do will be confusing in some way.

The problem is this:

 - it's pretty much impossible to name the sink in
   a way that expresses what it does or what it's
   good for (pulsecompressedaudiopassthroughsink
   is a tad unwieldy).

 - naming it after some technical implementation
   detail that's not even directly related to the
   main purpose of the element in an obvious
   way (e.g. 'dec') is also confusing. In this case
   even more so, because the whole point is
   to actually not decode anything.

 - ideally we would just replace the existing
   "pulsesink" element and proxy the properties,
   but we can't do that, because there might
   be code out there that relies on pulsesink
   deriving from GstAudioSink. So we need to
   keep pulsesink and add a new element
   with higher rank for autoplugging.

> imho the new sink is not more 'audio' than the other

That's true, but not the point. It's just a different name without using the
original one.

> pulseautosink, pulsedecsink, pulseconvsink, pulsesinkbin (may be not) or
> something like it

If it's a choice between those and pulsemagicsink, I'd still go for
pulsemagicsink I think ;)

 - pulsedecsink: even more confusing, see above

 - pulsesinkbin: meh, why is this better than pulseaudiosink?
   It's worse IMHO

 - pulseconvsink: abbreviation, and what does it convert? Again,
   the whole point is not to decode/convert (the "convert" bit
   is a really low-level implementation detail, to a normal
   technical user you just "pass AC-3 from here to there")

 - pulseautosink: I could live with that, but don't really see
   why it's better than just pulsesink or pulseaudiosink. What
   does the 'auto' stand for. From a user point-of-view,
   pulseaudio supports these features, and our element
   should expose that, so the "auto" is really just what the
   default behaviour should be from a user-point-of-view IMHO.

Applying the KISS principle, I still think pulseaudiosink is the least worst,
but if you find support for some other name, I could probably live with that as

Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the gstreamer-bugs mailing list