[Bug 673268] New: Failed to configure the video sink.

GStreamer (bugzilla.gnome.org) bugzilla at gnome.org
Sat Mar 31 18:44:44 PDT 2012

  GStreamer | common | 0.10.0

           Summary: Failed to configure the video sink.
    Classification: Platform
           Product: GStreamer
           Version: 0.10.0
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: Normal
         Component: common
        AssignedTo: gstreamer-bugs at lists.freedesktop.org
        ReportedBy: r.gao.unimelb at gmail.com
         QAContact: gstreamer-bugs at lists.freedesktop.org
     GNOME version: ---

Not sure what was the problem, gst actually plays video find by itself with no
problem using autovideosink (xvimagesink)

$ gst-launch-0.10 filesrc
location=/media/8C68A51968A502D6/TDDOWNLOAD/kmi039.wmv ! decodebin2 name=dec !
queue ! autovideosink dec. ! queue ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstAudioSinkClock
ERROR: from element
Output window was closed
Additional debug info:
xvimagesink.c(1311): gst_xvimagesink_handle_xevents ():
Execution ended after 12485428145 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

However, using totem to play, will get the following message:

$ totem /media/8C68A51968A502D6/TDDOWNLOAD/kmi039.wmv 
** Message: Error: Internal GStreamer error: pad problem.  Please file a bug at
gstplaysink.c(1362): gen_video_chain ():
Failed to configure the video sink.

note have tried setting gconf-editor key
/system/gstreamer/0.10/default/videosink to autovideosink or xvimagesink, but
no luck

Have tried reinstall gstreamer, no luck

Configure bugmail: https://bugzilla.gnome.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the gstreamer-bugs mailing list