[Bug 745880] sdp: SDP <-> GstCaps helper functions
GStreamer (GNOME Bugzilla)
bugzilla at gnome.org
Thu Aug 13 04:19:43 PDT 2015
https://bugzilla.gnome.org/show_bug.cgi?id=745880
Sebastian Dröge (slomo) <slomo at coaxion.net> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #308646|none |needs-work
status| |
--- Comment #14 from Sebastian Dröge (slomo) <slomo at coaxion.net> ---
Review of attachment 308646:
--> (https://bugzilla.gnome.org/review?bug=745880&attachment=308646)
Looks like a big improvement :) Just some minor comments. Also note that
sdpdemux has the same code
::: gst/rtsp-server/rtsp-media.c
@@ +3143,3 @@
/* do some tweaks */
GST_DEBUG ("mapping sdp session level attributes to caps");
+ gst_sdp_message_attributes_to_caps ((const GstSDPMessage *) sdp, caps);
Why the cast?
::: gst/rtsp-server/rtsp-sdp.c
@@ +153,3 @@
/* check for srtp */
+ gst_rtsp_stream_get_ssrc (stream, &ssrc);
+ base64 = (gchar *) gst_sdp_make_keymgmt (caps, ssrc);
Isn't this way of keymgmt specific to mikey? Maybe the API should be named like
that then
--
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs
mailing list