[Bug 725187] Add new multiappsrc or dynappsrc element with multiple output streams

GStreamer (GNOME Bugzilla) bugzilla at gnome.org
Mon Jul 20 01:20:56 PDT 2015


https://bugzilla.gnome.org/show_bug.cgi?id=725187

--- Comment #34 from Julien Isorce <julien.isorce at gmail.com> ---
Review of attachment 291612:
 --> (https://bugzilla.gnome.org/review?bug=725187&attachment=291612)

I suggest to also add an action signal "remove-source" (to dynamically remove a
source or else) and rename "new-appsrc" to "add-source".

::: gst/multiappsrc/Makefile.am
@@ +6,3 @@
+# compiler and linker flags used to compile this plugin, set in configure.ac
+libgstmultiappsrc_la_CFLAGS = $(GST_CFLAGS)
+libgstmultiappsrc_la_LIBADD = $(GST_LIBS) -lgstvideo- at GST_API_VERSION@
-lgstaudio- at GST_API_VERSION@

You do not depends on -lgstvideo- at GST_API_VERSION@
-lgstaudio- at GST_API_VERSION@. I do not think you even need $(GST_BASE_CFLAGS) /
$(GST_BASE_LIBS). I would suggest adding -lgstapp- at GST_API_VERSION@ even if for
now you are using appsrc's signal instead of gst_app_src_end_of_stream directly
for example.

::: gst/multiappsrc/gstmultiappsrc.c
@@ +56,3 @@
+ * gst_object_ref (appsrc2);
+ *
+ * g_signal_emit_by_name (multiappsrc, "new-appsrc", &appsrc1);

That would have been great to return an ID instead of the element directly. And
then translating app's signals:

g_signal_connect (multiappsrc, "need-data", G_CALLBACK (start_feed), id1);
g_signal_emit_by_name (multiappsrc, "push-buffer", id1, buff);

Maybe we can add this later and add signal action "new-appsrc-id":
g_signal_emit_by_name (multiappsrc, "new-appsrc-id", &id1);

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list