[Bug 631673] add "redirect" message to core

GStreamer (GNOME Bugzilla) bugzilla at gnome.org
Mon Jul 25 07:29:38 UTC 2016


https://bugzilla.gnome.org/show_bug.cgi?id=631673

Sebastian Dröge (slomo) <slomo at coaxion.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #329288|none                        |needs-work
             status|                            |

--- Comment #22 from Sebastian Dröge (slomo) <slomo at coaxion.net> ---
Review of attachment 329288:
 --> (https://bugzilla.gnome.org/review?bug=631673&attachment=329288)

Should be added to the docs (docs/gst/*-sections.txt) and the win32 .def file
(just run "make check-exports" and you see what I mean)

::: gst/gstmessage.c
@@ +2565,3 @@
+GstMessage *
+gst_message_new_redirect (GstObject * src, const gchar * location,
+    GstTagList * tag_list, const GstStructure * entry_struct)

Why don't you create an empty list here and just call
gst_message_add_redirect_entry()? Less code duplication :)

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list