[Bug 765435] plugins: rework dmabuf import

GStreamer (GNOME Bugzilla) bugzilla at gnome.org
Mon Jun 6 11:26:29 UTC 2016


https://bugzilla.gnome.org/show_bug.cgi?id=765435

sreerenj <bsreerenj at gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #328817|none                        |reviewed
             status|                            |

--- Comment #23 from sreerenj <bsreerenj at gmail.com> ---
Review of attachment 328817:
 --> (https://bugzilla.gnome.org/review?bug=765435&attachment=328817)

::: gst/vaapi/gstvaapivideobufferpool.h
@@ +77,3 @@
+  GST_VAAPI_VIDEO_BUFFER_POOL_OPTION_VIDEO_ALIGNMENT = (1u << 1),
+  GST_VAAPI_VIDEO_BUFFER_POOL_OPTION_GL_TEXTURE_UPLOAD = (1u << 2),
+};

How about giving a typedef name for this enum , may be like
GstVaapiVideoBufferPoolOption ?

It could be more readable.. For eg: the gst_vaapi_plugin_base_create_pool()
comment for options says
"@options: #GstBufferPool options encoded as bit-wise flags" I would prefer
"#GstVaapiVideoBufferPoolOption encoded as bit-wise flags"

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list