[Bug 777741] avwait: Rename timecodewait to avwait, add modes
GStreamer (GNOME Bugzilla)
bugzilla at gnome.org
Thu Jan 26 12:34:02 UTC 2017
https://bugzilla.gnome.org/show_bug.cgi?id=777741
Sebastian Dröge (slomo) <slomo at coaxion.net> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #344253|none |needs-work
status| |
--- Comment #4 from Sebastian Dröge (slomo) <slomo at coaxion.net> ---
Review of attachment 344253:
--> (https://bugzilla.gnome.org/review?bug=777741&attachment=344253)
This should probably go into a different plugin at some point
::: gst/timecode/gsttimecodewait.c
@@ +398,3 @@
+ } else {
+ GST_DEBUG_OBJECT (self, "First time reset in settings");
+ self->running_time_to_wait_for = GST_CLOCK_TIME_NONE;
Only if the mode has changed, otherwise you might wait again without reason. Or
maybe all these properties must only be set in NULL/READY but not in
PAUSED/PLAYING?
@@ +425,3 @@
}
+ if (self->mode != MODE_RUNNING_TIME) {
+ GST_DEBUG_OBJECT (self, "First time reset in video segment\n");
\n not needed
@@ +443,3 @@
g_mutex_lock (&self->mutex);
+ if (self->mode != MODE_RUNNING_TIME) {
+ GST_DEBUG_OBJECT (self, "First time reset in video segment\n");
\n not needed
@@ +527,3 @@
GstClockTime timestamp;
+ GstAvWait *self = GST_AVWAIT (parent);
+ /*GstClockTime duration; */
Why commented out?
@@ +538,3 @@
+ /*duration = GST_BUFFER_DURATION (inbuf);
+ if (duration != GST_CLOCK_TIME_NONE)
+ self->vsegment.position += duration; */
And this
--
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.
More information about the gstreamer-bugs
mailing list