[Bug 779765] GstUri: add function to parse uri and set properties to object

GStreamer (GNOME Bugzilla) bugzilla at gnome.org
Thu Mar 9 06:10:01 UTC 2017


https://bugzilla.gnome.org/show_bug.cgi?id=779765

Sebastian Dröge (slomo) <slomo at coaxion.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #347499|none                        |needs-work
             status|                            |

--- Comment #2 from Sebastian Dröge (slomo) <slomo at coaxion.net> ---
Review of attachment 347499:
 --> (https://bugzilla.gnome.org/review?bug=779765&attachment=347499)

::: gst/gsturi.c
@@ +2814,3 @@
+ */
+static gboolean
+gst_uri_query_to_boolean (gchar * value)

const I guess, safes us the cast below. Also this does not seem to be required
as a public function (and the documentation uses an old name of the function)

@@ +2840,3 @@
+ */
+void
+gst_uri_parse_uri (const GstUri *uri, GObject * obj)

This needs a more descriptive name, and especially needs to be distinguished
somehow from normal URI functions. This has nothing to do with URIs per se.

Maybe gst_object_set_properties_from_uri_query_parameters() or something.


Should also get a "filter" that gives properties that should be ignored, and
might make sense to have a "value transform" function per property that
converts the query string to the proper value.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
You are the assignee for the bug.


More information about the gstreamer-bugs mailing list