[0.11] gst-editing-services: ges: Update for registry API change

Edward Hervey bilboed at kemper.freedesktop.org
Mon Jan 2 06:58:27 PST 2012


Module: gst-editing-services
Branch: 0.11
Commit: 79ab1b516609ccbb13f540a8ce65b1a103d07d65
URL:    http://cgit.freedesktop.org/gstreamer/gst-editing-services/commit/?id=79ab1b516609ccbb13f540a8ce65b1a103d07d65

Author: Edward Hervey <edward.hervey at collabora.co.uk>
Date:   Mon Jan  2 15:58:17 2012 +0100

ges: Update for registry API change

---

 ges/ges.c |   13 ++++++-------
 1 files changed, 6 insertions(+), 7 deletions(-)

diff --git a/ges/ges.c b/ges/ges.c
index ff9a3e9..d05b0ef 100644
--- a/ges/ges.c
+++ b/ges/ges.c
@@ -36,13 +36,12 @@ static gboolean
 ges_check_gnonlin_availability (void)
 {
   gboolean ret = TRUE;
-  if (!gst_default_registry_check_feature_version ("gnlcomposition",
-          GES_GNONLIN_VERSION_NEEDED_MAJOR, GES_GNONLIN_VERSION_NEEDED_MINOR,
-          GES_GNONLIN_VERSION_NEEDED_MICRO)) {
-    GST_ERROR
-        ("GNonLin plugins not found, or not at least version %u.%u.%u",
-        GES_GNONLIN_VERSION_NEEDED_MAJOR,
-        GES_GNONLIN_VERSION_NEEDED_MINOR, GES_GNONLIN_VERSION_NEEDED_MICRO);
+  if (!gst_registry_check_feature_version (gst_registry_get (),
+          "gnlcomposition", GES_GNONLIN_VERSION_NEEDED_MAJOR,
+          GES_GNONLIN_VERSION_NEEDED_MINOR, GES_GNONLIN_VERSION_NEEDED_MICRO)) {
+    GST_ERROR ("GNonLin plugins not found, or not at least version %u.%u.%u",
+        GES_GNONLIN_VERSION_NEEDED_MAJOR, GES_GNONLIN_VERSION_NEEDED_MINOR,
+        GES_GNONLIN_VERSION_NEEDED_MICRO);
     ret = FALSE;
   }
   return ret;



More information about the gstreamer-commits mailing list