[gst-devel] Header file restructuring needed

David I. Lehn dlehn at vt.edu
Wed Feb 14 21:20:05 CET 2001

* Erik Walthinsen <omega at temple-baptist.com> [20010214 15:01]:
> The real solution is to split all the object headers into private and
> public headers.  The public header file would contain the typing macros,
> typedefs, public enums, external helper macros, and function prototypes.
> The real structure definitions and internal helper macros would be defined
> in the private header.

By 'private' headers do you mean private to gstreamer or private to that
class?  If it's just private to each class then just put the stuff at
the top of the .c file.  Kind of like what newer glib code is doing.

> The naming convention for these headers is still escaping me.  The header
> names we have now must be used for the public headers, but the private
> headers could be named in any of several ways:
> gstpad.ph
> gstpad.hp

These are too non-standard.  Would be nice to stick to .h for editor
file type detection and so on.

> gstpad_p.h
> gstpad_private.h
> etc...

You could try:
 public: gstpad.h
 private: _gstpad.h
That's fairly clear and goes along with private data naming that many
people use.

David I. Lehn <dlehn at vt.edu>  | http://www.lehn.org/~dlehn/
Computer Engineering Graduate @ Virginia Tech in sunny Blacksburg, VA

More information about the gstreamer-devel mailing list