[gst-devel] Re: divxenc testing

Joshua N Pritikin vishnu at pobox.com
Wed May 7 23:02:05 CEST 2003

On Wed, May 07, 2003 at 06:16:43PM +0200, Jorge Robles Nogales wrote:
> I have tried your patch. The problem that you have in:
> > joshua at emit:~/gst/gstreamer/tools$ ./gst-launch filesrc
> >location=/local/aleader/ljr.mpg ! mpegdemux name=demux demux.video_00 >
> ! mpeg2dec ! colorspace ! xvidenc ! avimux ! filesink 
> > location=/tmp/test.m1v
> is the way that you use avimux, you should have used \!avimux0.video_00
> for the dynamic pad.

That's encouraging, however, your launch line looks like the
old launch syntax.  Are you using 0.6.1?  i'm using CVS HEAD.

> I have tried using your patch this: gst-launch  avimux ! filesink
> location=./../test.avi v4lsrc ! colorspace ! xvidenc \!avimux0.video_00
> and it "seems" that it works.

Wow, cool.  It doesn't work for me.  See the attached session log.

> After that, if you tried to play the created file you would realize that
> there is a problem in the MPEG4 header, and the player will no be able
> to play it, so what you should do is to try to generate the mpeg4 header
> properly.
> I will look more carefully your patch, and I will try to help you.

That would be great.

Victory to the Divine Mother!!         after all,
  http://sahajayoga.org                  http://why-compete.org
-------------- next part --------------
joshua at emit:~/gst/gstreamer/tools$ ./gst-launch filesrc location=/local/aleader/ljr.mpg ! mpegdemux name=demux demux.video_00 ! mpeg2dec ! colorspace ! xvidenc ! avimux name=mux mux.video_00 ! filesink location=/tmp/test.m1v
INFO (  645: 0) Initializing GStreamer Core Library version 
INFO (  645: 0) CPU features: (0081813f) MMX 
INFO (  645: 0) registry: loaded user_registry in 0.689822 seconds
INFO (  645: 0) registry: loaded global_registry in 0.031482 seconds

** (process:645): WARNING **: could not link mux to filesink0
WARNING: erroneous pipeline: could not link xvidenc0 to mux
         Trying to run anyway
RUNNING pipeline

(process:645): GStreamer-CRITICAL **: file gstpad.c: line 2919 (gst_pad_send_event): assertion `GST_IS_PAD (pad)' failed

More information about the gstreamer-devel mailing list