[gst-devel] Bug or newbie problem with gstreamer-0.8.0

John Murdie john at cs.york.ac.uk
Fri Apr 2 08:52:29 CEST 2004

Oops, I sent this to gstreamer-bugs. Probably not the right list - my

On Fri, 2004-04-02 at 17:35, John Murdie wrote:
> I've recently started to experiment with gstreamer, appreciating that it
> is still being developed but finding that it has an elegant and very
> adaptable underlying model. (That was the flattery, now the request for
> assistance!) I first installed gstreamer-0.7.3 and gst-plugins-0.7.3
> from source on a Slackware Linux 9.0 system under /usr/local (which
> already had gstreamer/gst-plugins-0.6.0) so I could experiment and
> learn. I installed 0.7.3 because that was the latest source I could find
> at the time on SourceForge. My little test programs worked fine, apart
> from a problem with the afsrc plugin. I then installed 0.8.0, which
> fixed the afsrc problem (which I don't think worth describing here) only
> to find one of my first example programs no longer works correctly. I
> thought I'd ask people here to comment before I bugzilla it - after all,
> I might be in error.
> I attach the .c and Makefile for my example program, in which I try out
> seeking in an MP3 audio stream. I pinched most of the source from the
> very useful example gst-plugins/examples/seeking/seek.c. In 0.7.3, both
> this executable and the one I build from my .c work fine, but in 0.8.0
> the two programs show (different?) odd behaviour. I'm wondering whether
> this is a result of a genuine bug or something that has gone wrong with
> my build. Can anyone confirm (and suggest a diagnosis for) my problem?
> The 0.7.3 seek works fine, but the 0.8.0 seek (tried with an MP3 file -
> 'seek 0 song.mp3', I'm sure you can find an MP3 to try) moves its slider
> rapidly to the extreme right whenever I let go of it, though the track
> keeps on playing until it ends.
> My program is supposed to play an MP3 file, but rewind the pipeline to
> the start when it reaches halfway through the input. This works fine
> with 0.7.3, but with 0.8.0 the seek has no effect, and the seek attempt
> repeats indefinitely.
> John A. Murdie
> Department of Computer Science
> University of York

More information about the gstreamer-devel mailing list