[gst-devel] Bugs in ffenc_*/ffdec_*?

Deeptendu Bikash dbikash at gmail.com
Mon Aug 14 08:28:10 CEST 2006


Are there known bugs with ffenc/ffdec pair? If I encode a file with a ffenc
of a particular codec, then I should be able to decode the file using ffdec
of the same codec, right?

I tried with h263 and mpeg4, but got the same result:

gst-launch  videotestsrc ! ffenc_mpeg4 ! filesink location=videotestsrc.m4v
gst-launch filesrc location=videotestsrc.m4v ! caps="video/mpeg,
width=(int)320, height=(int)240, framerate=(fraction)30/1,
mpegversion=(int)4, systemstream=(boolean)false" ffdec_mpeg4 !
ffmpegcolorspace ! xvimagesink

ERROR: from element /pipeline0/ffdec_mpeg40: Internal GStreamer error:
negotiation problem.  Please file a bug at
Additional debug info:
gstffmpegdec.c(1276): gst_ffmpegdec_chain (): /pipeline0/ffdec_mpeg40:
ffdec_mpeg4: input format was not set before data start
ERROR: pipeline doesn't want to preroll.

Any suggestions?


Note: For MPEG1 and 2 Video, I used ffenc_mpeg1video/ffenc_mpeg2video and
mpeg2dec, and this worked.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20060814/95b2b086/attachment.htm>

More information about the gstreamer-devel mailing list