[gst-devel] RTSP/RTP streaming - setting correct clock rate

Deeptendu Bikash dbikash at gmail.com
Fri Aug 25 13:20:27 CEST 2006

Thanks for the explanation Wim. I think I understand now.

On 8/25/06, Wim Taymans <wim at fluendo.com> wrote:
> On Fri, 2006-08-25 at 15:37 +0530, Deeptendu Bikash wrote:
> > Hi,
> >
> > This problem has been solved!
> >
> > This was not a clock rate problem at all. After debugging, I found
> > that the clock rate was being correctly set, after all.
> That subset error you get is pretty harmless and should be solved in
> CVS, as well.
> >
> > Setting the 'sync' property of the xvimagesink to false solved the
> > problem!
> >
> > Can anyone explain about the sync property and why setting it to false
> > caused the video to play smoothly?
> rtspsrc acts as a live source (combining other UDP live sources,
> actually) it however does not expose a clock with the rate at which it
> produces data (yet), neither does it timestamp based on the pipeline
> clock. In short, timing is totally screwed and setting sync=false on the
> sinks makes them play the data at the rate at which they receive it. The
> skipping and wrong framerate you see is because the sinks try to
> synchronize the (wrong) buffer timestamps against the clock, this will
> either result in a dropped frame (when it's too late) or in the display
> of an emergency frame (when no frame has been played for 1 second, it
> displays whatever is gets regardless of timestamps so that the user at
> least sees something).
> Hope that helps,
> Wim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20060825/a1c794ee/attachment.htm>

More information about the gstreamer-devel mailing list