[gst-devel] Re: Encoding with FAAC

Michael mkaiser at oxy.edu
Wed Jan 11 16:50:02 CET 2006

I'm sorry about the formatting on the first message. Here it is again,
hopefully a bit more readable, and slightly updated.

I'm trying to rip CDs onto my computer using Sound Juicer. I've
created a profile for encoding with FAAC in GMAudio Profiles with the
"audio/x-raw-int,rate=44100,channels=2 ! faac name=enc",
"audio/x-raw-int,rate=44100,channels=2 ! faac profile=1", and
"audio/x-raw-int,rate=44100,channels=2 ! faac".

All three ways, nothing complains when I rip a CD, but playing the AAC
files back with "totem /path/to/file.m4a", I get
"GStreamer-WARNING **: element internal_thread claimed state-change
success,but state didn't change to PLAYING. State is PAUSED
(NONE_PENDING pending), fix the element"
in the terminal, and Totem says it "Could not determine type of
stream." iTunes doesn't like the files, either.

"gst-launch filesrc location=/path/to/file.m4a ! faad ! osssink" (or
with alsasink)
gives "RUNNING pipeline ..." and then, after a while,
"Execution ended after 3695 iterations (sum 296036133000 ns, average
80118033 ns, min 111000 ns, max 1723749000 ns)."
I hear no sound, though, but I don't hear sound with AAC files that
work in Totem.

I've tried with multiple CDs, all with the same result. I've also
tried converting an mp3 into AAC using
"gst-launch filesrc location=/path/to/file.mp3 ! mad ! faac name=enc !
filesink location=/path/to/file.m4a"
and acheived similar results.

I would really appreciate any help I could get in figuring out what's
going wrong. Also, I wasn't able to find an explanation of the options
"profile=1" or "name=enc" anywhere; is there any documentation on what
all the options for the plugins are and how to use them?

Thank you for your help.

More information about the gstreamer-devel mailing list