[gst-devel] I can't play an MP3 file through RTSP/RTP

Fabrice Triboix Fabrice.Triboix at imgtec.com
Thu Nov 2 12:57:27 CET 2006

Hi Lutz,

I got the cvs head for gstreamer, gst-plugins-base and gst-plugins-good.

Now it is a bit better: I hear about half a second of my MP3 file!
I use the same gst-launch command than in my previous email for that.

I can't use playbin because I do not run gstreamer on my PC, but on a remote development machine. I tried to look quickly if I can tell playbin to redirect the output, but it is only to a GstElement (audio-sink property).
So I have to do some coding, I guess!

I also tried using helix server instead of fenice, but I get this:
ERROR: from element /pipeline0/rtspsrc0/udpsrc0: Internal data flow error.

I guess this is because fenice provides RTP interleaved in RTSP only, while helix will send RTP over UDP by default.

Any comments much welcomed!


-----Original Message-----
From: Lutz Müller [mailto:lutz at topfrose.de] 
Sent: 01 November 2006 19:42
To: Fabrice Triboix
Cc: gstreamer-devel at lists.sourceforge.net; Matt Vinall
Subject: Re: [gst-devel] I can't play an MP3 file through RTSP/RTP

On Wed, 2006-11-01 at 17:35 +0000, Fabrice Triboix wrote:
> I am currently trying to play an MP3 file through RTSP/RTP, without
> success so far.

There have been quite a few changes to the RTSP plugin in CVS (and
related plugins). Have you tried CVS head? Try the playbin element
(playbin uri=rtsp://...) as pads gets created dynamically and playbin
now should be able to handle that.


Lutz Müller <lutz at topfrose.de>
This message is subject to Imagination Technologies' e-mail terms: http://www.imgtec.com/e-mail.htm

More information about the gstreamer-devel mailing list