[gst-devel] Linking ffdec_h264 and ximagesink

Vinay Krishnamurthy mailtovins at gmail.com
Tue Aug 28 09:16:27 CEST 2007

Hello All,

I am trying to link ffdec_h264 and ximagesink for an avi pipeline. My
pipeline is,
gst-launch-0.10 filesrc location=test.avi ! avidemux ! ffdec_h264 !
ffmpegcolorspace ! ximagesink.
However, when I run this pipeline, I get the following error,

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /pipeline0/avidemux0: Internal data stream error.
Addition debug info:
gstavidemux.c(3742): gst_avi_demux_loop ( ): /pipeline0/avidemux0:
streaming stopped, reason not-negotiated
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline

I then tried linking it with sdlvideosink. I could link it properly, but I
could not see the displayed image properly. Is there something wrong in my
linux "X" settings? I am using vmware for my development.

Can anybody help me?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20070828/4d395ad4/attachment.htm>

More information about the gstreamer-devel mailing list