[gst-devel] problems with video

Vinod Nanjaiah Vinod_Nanjaiah at mindtree.com
Wed Dec 12 16:58:49 CET 2007

Yup! I missed out linking the gstinterfaces-0.10
It now builds when I use gst_x_overlay_set_xwindow_id.

For video seek, I tried a few combinations of the flags. 
I thought GST_FMT_DEFAULT would take FRAMES in case of video and so tried
that. But that didn't work. 
I am yet to try out gst_element_seek_simple with the flags that Tim has
Like Stefan had mentioned, I am using GST_SEEK_FLAG_NONE and it works for

Thank you!

> 1> Seek on video:
> Should I use some specific flags with gst_element_seek () to be able to
> on video?
> I tried some possible combinations but was not successful.

It would be useful to know what you've tried exactly ...

In any case, in a playback situation you usually want to

 - seek in GST_FORMAT_TIME (remember the time is in nanoseconds)
 - use gst_element_seek_simple()

> 2> I am trying to use gst_x_overlay_set_xwindow_id () in my code, but it
> gives link errors when building. 
> Can someone please give me some pointers.

you need to add

 `pkg-config --cflags gstreamer-plugins-base-0.10`

to your CFLAGS / compiler flags and

 `pkg-config --libs gstreamer-plugins-base-0.10 -lgstinterfaces-0.10`

to your LIBS / linker flags as per:




Message: 2
Date: Tue, 11 Dec 2007 18:25:46 +0000
From: Robert <RobertCL at iname.com>
Subject: Re: [gst-devel] problems with video
To: Tim M?ller <t.i.m at zen.co.uk>
Cc: gstreamer-devel at lists.sourceforge.net
Message-ID: <1197397546.8652.5.camel at amd.dragonfly.dnsalias.net>
Content-Type: text/plain; charset=ISO-8859-1

On Tue, 2007-12-11 at 17:58 +0000, Tim M?ller wrote:
> On Tue, 2007-12-11 at 17:23 +0000, Robert wrote:
> > I was hoping someone would answer this because I am seeking in video,
> > but sometimes, it causes a segfault and I was wondering if it was
> > because I'm doing something wrong in how I'm doing it.  I'm using
> > gst_element_seek too, but haven't tried playing around with different
> > parameters.
> It should never crash, so if that's something you can reproduce, please
> file a bug with a stack trace (and preferably make a sample file
> available somewhere so we can try to reproduce the problem).  If you
> can, also try CVS of things to see if it's been fixed already.

My guess is that it isn't a bug, as it doesn't happen all the time.
It's more likely something that I'm not doing quite right.  The annoying
thing is that it isn't very reproducable - it only happens sometimes,
and not on all of my PC's.  I have other "problems" in my app at the
minute in that I sometimes get a "bad drawable" x-window error - I guess
it's all related, but I haven't really had the time to track down the
problem yet.


This message (including attachment if any) is confidential and may be privileged. If you have received this message by mistake please notify the sender by return e-mail and delete this message from your system. Any unauthorized use or dissemination of this message in whole or in part is strictly prohibited.
E-mail may contain viruses. Before opening attachments please check them for viruses and defects. While MindTree Consulting Limited (MindTree) has put in place checks to minimize the risks, MindTree will not be responsible for any viruses or defects or any forwarded attachments emanating either from within MindTree or outside.
Please note that e-mails are susceptible to change and MindTree shall not be liable for any improper, untimely or incomplete transmission.
MindTree reserves the right to monitor and review the content of all messages sent to or from MindTree e-mail address. Messages sent to or from this e-mail address may be stored on the MindTree e-mail system or else where.

More information about the gstreamer-devel mailing list