[gst-devel] mpeg2 encoding

jodim jodim at innomak.co.uk
Mon Feb 19 22:48:07 CET 2007

    Would to thank you for your answers regarding multiple outputs. It 
was spot on. Now we seem to be stuck yet again, unfortunately.

Basically we are trying to decode a previously encoded mpeg file encoded 
with the latest gstreamer libraries with the following command line:

gst-launch-0.10 videotestsrc num-buffers=1000 ! ffenc_mpeg2video 
buffer-size=0 gop-size=15 me-method=5 rtp-payload-size=0 bitrate=300000 
! filesink location=videotestsrc.m1v

this seems to create successfully videotestsrc.m1v locally. However the 
size of the file its just 0 bytes. What is wrong? as this seemed to work 
with gst 0.10.0 (using default properties) but now with 0.10.2  fails to 
produce  a playable  file even if I explicitly set all properties to a 
value, as suggested by an outstanding bug on version 0.10.2.

We know it worked with 0.10.0 because the file played successfully using 
ffmpeg's mplayer.

Nevertheless, even with gst 0.10.0 have been unable to  decode the  mpeg 
file using ffdec_mpeg2video or ffdec_mpeg1video. by using the following 
command line ( and several variants ):

gst-launch-0.10 filesrc location=videotestsrc.mpg ! ffdemux_mpeg 
name=demux ! ffdec_mpeg2video name=dec skip-frame=0 lowres=0 ! 
ffmpegcolorspace ! queue ! ximagesink

or playbin for that matter:

gst-launch-0.10 playbin uri=file://./videotestsrc.m1v

BTW, how can one specify encoding to mpeg2 using ffenc_mpeg2video? as it 
seems to default to mpeg version 1 when it worked?.

Many thanks in advance for your help.

Best Regards,

More information about the gstreamer-devel mailing list