[gst-devel] tcpsink - tcpsrc- gdp problem

xavier.grasa at iss-profesionalia.com xavier.grasa at iss-profesionalia.com
Tue Apr 29 11:39:58 CEST 2008


I'm trying to send-receive raw video on the same pc using gdp and tcp for
test purposes. The following pipelines have been run on a Linux system as
well as on a winxp pc.

send pipeline:

gst-launch --gst-debug-no-color -v -m videotestsrc do-timestamp=true
is-live=true ! gdppay ! queue ! tcpserversink port=1234 host=localhost

receive pipeline:

gst-launch --gst-debug-no-color -v -m tcpclientsrc port=1234
host=localhost ! gdpdepay !  queue ! ffmpegcolorspace !

They work fine on the Linux machine, but not on the winxp one. The receive
pipeline only gets one frame, it shows it, and then freezes. The
connection is not lost, but it won't try to read more frames from the
socket. I've tried to debug the tcpclientsrc filter with MSVS, but it
loses the thread scope after the first frame is read from the socket.
Similar behaviour is observed when debugging the tcpserversink after
writing the first frame. I wondered if it was a sync problem with
directdrawsink, but tried the same pipeline with testsink and got the same

¿Any idea of what's wrong?
don't know if it has anything to do with it, but  the tcp packet size in
winxp is 8K, whereas in Linux is 16K.

Thanks, any help will be appreciated.


More information about the gstreamer-devel mailing list