[gst-devel] Reading and displaying a rtsp stream

Ekrem SEREN ekrem.seren at gmail.com
Mon Aug 4 10:26:39 CEST 2008


Sorry for the delayed reply.

2008/7/31, Aurelien Grimaud <gstelzz at yahoo.fr>:
> Beside, in your paste, there is no ffmpegcolorspace at all.
> I tried your pipeline with some movies (audio/video).

I messed command and outputs a little in the previous post, sorry.
Now, I've tried some things;

This works OK, no problem at all;
$ gst-launch -v playbin uri=rtsp://

But this opens a video windows but it did not play anything;
$ gst-launch -v rtspsrc location=rtsp:// !
decodebin ! ffmpegcolorspace ! autovideosink
(output is attached)

So, I am missing something that playbin has but can't figure out what it is?

UYGUN Teknoloji Bilişim Hiz.Tic.Ltd.Şti.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gst-rtsp-err-output.log
Type: application/octet-stream
Size: 8407 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080804/174fb8f6/attachment.obj>

More information about the gstreamer-devel mailing list