[gst-devel] FFMUX_FLV issue with H264 stream

Kumar kumarkm at tataelxsi.co.in
Thu Dec 4 11:34:48 CET 2008

Hi All,

When I tried muxing H264 stream using the standalone ffmpeg application, The
playback is happening on Adobe Flash Player.

Command line args I used is as follows:
./ffmpeg -i /home/CodecH264.264 -f flv -vcodec copy /home/Test_ffmpeg.flv

But when I tried to mux using gstreamer pipelinethe (using FFMPEG Gstreamer
plug-in, gst-ffmpeg-0.10.5 ), the playback is not happening on
Adobe Flash Player.

Pipeline used for muxing is as follows :
gst-launch-0.10 filesrc location/home/CodecH264.264 ! h264parse !
video/x-h264, width=1280, height=720, framerate=30/1 !  ffmux_flv
! filesink location=/home/Test_gst.flv

Pls help me solve this issue. Is there anything wrong in the Gstreamer
pipeline that I have used or any code modification is required in Gstreamer
FLV muxer plugin....?

Kumar KM

The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s) and may contain proprietary, confidential or privileged information. If you are not the intended recipient, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately and destroy all copies of this message and any attachments contained in it.

More information about the gstreamer-devel mailing list