[gst-devel] Help! a very simple question..

Yue Li liyue99 at gmail.com
Wed Feb 27 07:43:04 CET 2008


I'm new to Gstreamer and this mail list. So I know maybe my question
is too stupid.
But I really couldn't find the answer and need your help.

I just tried to decode a mpeg file like below:

gst-launch filesrc location=mpeg2.mpg ! mpegdemux name=demux video_00!
{ queue ! mpeg2dec ! xvideosink }

but got the error message :

WARNING: erroneous pipeline: no element "video_00"

Then I tried:

gst-launch filesrc location=mpeg2.mpg ! mpegdemux ! fakesink

and got:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /pipeline0/filesrc0: Internal data flow error.
Additional debug info:
gstbasesrc.c(2099): gst_base_src_loop (): /pipeline0/filesrc0:
streaming task paused, reason not-linked (-1)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...

I know this question may be too simple to you but please help me...

Thank you!
Yue Li

More information about the gstreamer-devel mailing list