[gst-devel] Streaming an AVI using RTP

Néstor Morales Hernández neztol at gmail.com
Fri Feb 29 14:38:15 CET 2008


I'm new in using GStreamer libraries. I want to send an AVI stream
(DivX5.0without audio) using RTP on Windows. I've tried the following

gst-launch-0.10 filesrc
!video/x-msvideo !ffdemux_avi !video/mpeg4 !ffdec_mpeg4 !ffenc_mpeg2video !
ffmux_mpegts ! rtpmp2tpay pt=96 ! udpsink host= port=5000

, but I get this:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

and it stays in this state, but never finishes! i've also tried other
commands, like this one:

gst-launch-0.10 uridecodebin
!ffenc_h263p ! video/x-h263 ! rtph263ppay pt=96 ! udpsink
host= sync=false

, but in this case, I get:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /pipeline0/uridecodebin0/source: Internal data flow
Additional debug info:
(function) (): /pipeline0/uridecodebin0/source: streaming task paused,
reason not-linked (-1)
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...

How can I do that? Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080229/6a233503/attachment.htm>

More information about the gstreamer-devel mailing list