[gst-devel] rtp streaming

Seress Zoltan egyvoltgepesz at freemail.hu
Tue Jun 24 16:01:52 CEST 2008


I have a little problem.

I wanted to send and receive raw video data on the same PC via rtp.  But I couldn't do that properly. It froze after getting the first frame.
Then I tried to do this via tcp and searched for the problem I found this solution:

1, videotestsrc 
gst-launch videotestsrc pattern=snow do-timestamp=true is-live=true ! gdppay ! queue ! tcpserversink port=1234 host=localhost
2, or webcam
gst-launch v4lsrc device=/dev/video0 ! gdppay ! queue ! tcpserversink port=1234 host=localhost

gst-launch -v tcpclientsrc port=1234 host=localhost ! gdpdepay !  queue ! ffmpegcolorspace ! xvimagesink

This works well. But when I tried to do the rtp the way like this...

gst-launch -v gstrtpbin name=rtpbin videotestsrc pattern=snow ! ffenc_h263p ! rtph263ppay ! queue ! rtpbin.send_rtp_sink_0 rtpbin.send_rtp_src_0 ! udpsink host=localhost port=5000 rtpbin.send_rtcp_src_0 ! udpsink port=5001 sync=false async=false udpsrc port=5005 ! rtpbin.recv_rtcp_sink_0

gst-launch -v gstrtpbin name=rtpbin udpsrc caps="application/x-rtp,media=(string)video,clock-rate=(int)90000,encoding-name=(string)H263-1998"  port=5000 ! rtpbin.recv_rtp_sink_0 rtpbin. ! rtph263pdepay ! ffdec_h263 ! queue ! xvimagesink udpsrc port=5001 ! rtpbin.recv_rtcp_sink_0 rtpbin.send_rtcp_src_0 ! udpsink port=5005 sync=false async=false

... it still didn't work.

Any help? Thx in advance.


Elvéreztek a kabriók a törésteszten! 

Megdöbbentő törésteszt eredmények az automenedzser.hu-n fotóval és videóval:

www.automenedzser.hu/top/kabrio_toresteszt http://ad.adverticum.net/b/cl,1,6022,272425,328531/click.prm

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080624/ce80ca1a/attachment.htm>

More information about the gstreamer-devel mailing list